2016-08-09 127 views
0

nicht starten cider mit M-x cider-jack-in mit Clojure Projektdatei im aktuellen Puffer auf Emacs 24.4.1 starten. Ich bekomme error in process sentinel: Could not start nREPL serverFehler im Prozess Sentinel: Konnte nREPL Server

benötigt nREPL separate Installation ... ist das ein Fehler, den jemand anderes mit 24.4.1 erlebt?

Nachrichten Puffer: Starting nREPL server via /usr/bin/lein update-in :dependencies conj \[org.clojure/tools.nre\ |11:56:07 hello: |pl\ \"0.2.12\"\] -- update-in :plugins conj \[cider/cider-nrepl\ \"0.14.0-SNAPSHOT\"\] -- re\ |11:56:07 hello: |pl :headless... |11:56:08 hello: |error in process sentinel: nrepl-server-sentinel: Could not start nREPL server: ^[[?25h^[[0G\

+0

Welche Version von CIDER verwenden Sie? Können Sie Ihren '* Nachrichten *' Puffer anzeigen? – OlegTheCat

+0

Cider-Version: '' '20160122.440''' @OlegTheCat – sjt003

+0

Ich meine Version, die über' M-x Cider-Version 'erhalten wird. Kannst du das zeigen? Es scheint auch ein Problem in Ihrem Projekt zu sein (ich sehe jedoch keine Ausnahmen in '* Messages *' Puffer, seltsam ...). Führt das Starten von REPL von der Konsole aus, z. "Leins repl"? – OlegTheCat

Antwort

0

Einfach darum, die richtigen Versionen von lein und Clojure (Skript) mit und RTFM auf https://github.com/clojure-emacs/cider-nrepl. Um dies zu beheben, musste ich Clojure auf 1.7+ und lein auf 2.5.2 aktualisieren. Nach diesen Upgrades hat alles gut funktioniert.